x
dustball
Browser Support
MindSay should work with any modern web browser now, including Internet Explorer 5.5+, Mozilla/Netscape/Firefox, Opera, and Safari.